Category Archives: SCADA

Редактор мнемосхем Simplight

Редактор мнемосхем предназначен для:

— Создания мнемосхем технологических процессов.

— Привязки тегов ввода/вывода к графическим элементам.

Рабочие области

Рабочее пространство Редактора мнемосхем можно разделить на 4 функциональные области.

1 – Главное меню.

2 – Редактор свойств – позволяет установить свойства графических компонентов.

3 — Библиотека элементов – содержит графические компоненты. Компоненты помещаются на мнемосхему перетаскиванием.

4 — Область мнемосхемы

5 – Панель выбора канала для привязки(изначально скрыта)

 

При нажатии на пункт «открыть» появляется окно, в котором можно также установить мнемосхему в автозагрузку при запуске Монитора (либо удалить из автозагрузки), удалить мнемосхему, переименовать мнемосхему. Достаточно лишь нажать на нужной мнемосхеме правой кнопкой мыши и выбрать пункт в контекстном меню

.

Пункт Вид

 

 

Параметры эмуляции значений сигнала.

При эмуляции формируется пилообразный сигнал с заданной амплитудой и постоянной скоростью изменения. Также возможно ручное задание значения эмулирующего тега.

Статусбар

Контекстное меню компонента

Контекстное меню вызывается нажатием на компонент правой клавишей мыши.

Установка свойств мнемосхемы

Кликните левой кнопкой мыши по пустому месту мнемосхемы. В области свойств можно поменять цвет области мнемосхемы, а также установить запрос авторизации при открытии мнемосхемы в Редакторе мнемосхем и загрузке мнемосхемы в Мониторе.

 

Перенос данных и настроек Simp Light

Если компьютер, на котором ведется разработка проектов Simp Light и компьютер, который является опросной станцией на базе сервера Simp Light — это 2 разных компьютера (либо по какой-то причине производится замена компьютера с серверной частью Simp Light на другой компьютер) – возникает потребность перенести все данные проекта на второй ПК, то есть, создав очередную версию проекта со своими схемами и каналами на своем компьютере, разработчику потребуется перенести файлы проекта на компьютер, который будет раздавать данные клиентам (либо который будет работать просто как сервер Simp Light без клиентов).

В этом случае нужно проделать некоторые действия, чтобы корректно перенести все настройки проекта (мнемосхемы, базу данных, базу алармов, а также настройки OPC-сервера) на другой компьютер.

Шаги переноса

1. Сохранить последние настройки OPC–сервера на компьютере разработки.

2. Установить OPC-сервер на рабочем (раздающим данные) компьютере (сервере Simp Light), сконфигурировать его (или загрузить сохраненную ранее конфигурацию).

3. Установить SimpLight на рабочий компьютер (на диск “С”!).

4. Если копируем файлы Simp Light-сервера по локальной сети, то нужно запретить и снова “расшарить” папку “С:slProject” компьютера-разработчика (делаем так-правой кнопкой мыши кликаем по папке “С:slProject” — “общий доступ и безопасность…” — снимаем галку у пункта “открыть общий доступ к этой папке” — жмем кнопку “применить” — ставим галку у пункта “открыть общий доступ к этой папке” и у пункта “разрешить изменение файлов по сети” — жмем кнопку “OK”).

5. Скопировать в папку “С:slProject” рабочего компьютера следующие папки: “data” (база данных, алармы), “forms” (Ваши мнемосхемы) и файл “Passport.slp”.

6. В конфигураторе каналов Simp Light: имя и пароль на рабочем компьютере после установки SimpLight устанавливается по умолчанию как user — заменить их на свои, если нужно.

7. Запретить и снова “расшарить” папку “С:slProject” рабочего компьютера-сервера Simp Light (чтобы клиенты Simp Light подцепились нормально).

8. Запустить модуль Монитор (и/или другие модули) на рабочем компьютере.

 

    Настройка сетевых подключений simplight

    Получать данные с опросных станций на удалённые ПК можно двумя разными способами:

    1. Посредством WEB-интерфейса.

    Позволяет видеть данные в “легкой” форме на удаленной машине посредством интернет браузеров (данные обновляются каждые 10 сек.). Требуется только установить сервер SIMP Light на одном компьютере, запустить на нем Монитор и запустить интернет браузеры на удаленных машинах.

    2. Посредством TCP/IP соединения.

    Для этого способа нужно установить серверную и клиентские части SIMP Light PRO/ENT.

    1. Получение данных посредством WEB-интерфейса

    (доступно во всех версиях SIMP Light)

    1.1 Установите SIMP Light.

    1.2 Настройка модуля “Редактор каналов”.

    • запустите “Редактор каналов”.
    • в меню “Настройки” выберите пункт “Общие настройки”.
    • поставьте галку для пункта “Разрешить WEB сервер”.
    • нажмите кнопку “Применить”.
    • в меню “Редактора каналов” нажмите пункт “Сохранить”.
    • закройте редактор.

    1.3 Запустите модуль Монитор.

    1.4 Запустите интернет браузер(Opera, FireFox, Chrome) на удаленном компьютере.

    1.5 В строке адреса браузера удаленного компьютера введите IP адрес компьютера, на котором установлен сервер SIMP Light и нажмите Enter. Появится примерно такая картинка:

    Данные на WEB странице обновляются 1 раз в 10 секунд.

     

    2. Получение данных посредством TCP/IP соединения

    (доступно в версиях SIMP Light PRO и ENT)

    Схематично работу можно представить так:

    2.1 Установите SIMP Light PRO/ENT в режиме сервер на опросную станцию (тип установки — сервер или клиент выбирается в ходе инсталляции).

    2.2 Сконфигурируйте теги (каналы), которые будете использовать, в модуле Редактор каналов на опросной станции и создайте нужные Вам мнемосхемы.

    2.3 Установите SIMP Light PRO/ENT в режиме клиент на другие компьютеры, на которые необходимо получать данные.

    2.4 При установке SIMP Light — клиента нужно указать IP адрес сервера (если еще не известен – введите любой IP, позже можно будет поменять на реальный):

    2.5 Запустите модуль Монитор на опросной станции, а затем на SIMP Light PRO/ENT — клиентах. Таким образом в Мониторе каждого клиента будут отображаться данные по каналам и мнемосхемы опросной станции под управлением SIMP Light PRO/ENT.

    2.6 Возможен не только просмотр, но и изменение значений каналов с Сетевых клиентов.

     

      Монитор simpLight

      Монитор реализует следующие функции:

      — приём данных от приборов;

      — обработка данных (математические формулы и СКРИПТЫ);

      — архивирование данных;

      — контроль входных данных на предмет выхода их из диапазона уставок (одноуровневые алармы – верхняя и нижняя границы);

      — отображение поступающих данных на мнемосхемах, в табличном виде и на трендах

      В Монитор интегрирована защита от несанкционированного закрытия программы – если включен режим авторизации.

      1 — Главное меню

      2 — Список параметров (тегов) — в этом окне отображаются все теги проекта. При клике по значку со знаком i будет отображено окно с информацией о канале (значок появится при наведении на имя канала указателя мыши). При двойном клике по параметру будет выведен тренд канала.

      3 — Оперативный журнал отклонений — в этом окне отображаются параметры, вышедшие за уставки. Кликом по параметру осуществляется квитрирование (системе посылается сигнал, что оператор заметил и принял к сведению выход параметра за норму)

      4 — Архивный тренд – на тренде отображаются «живые» или архивные данные по выбранному параметру.

      5 – Окно свойств канала.

      Главное меню

      Работа с мнемосхемой

      При наведении курсора мыши на графический объект, будет показана краткая информация о канале, к которому привязан этот компонент (имя канала, нижняя и верхняя уставки). При двойном клике по графическому компоненту будет выведен его тренд.

      Работа с архивным трендом

      Работа со списком Алармов (Нарушений)

      В списке нарушений видны все параметры, которые вышли за норму (верхняя и нижняя границы нормы устанавливаются в Редакторе каналов). При клике мышью по каналу в таблице будет считаться, что Оператор заметил нарушение и в базу данных нарушении запишется сообщение о Квитировании нарушения. При этом параметр в таблице перестанет моргать.

      Работа с Архивным журналом тревог

      Для того что бы посмотреть историю алармов (т.е. когда и какой параметр выходил за норму и сделал ли что то оператор) нужно в Меню выбрать пункт Вид, а затем Журнал тревог.

      Выбрав в дереве слева необходимый год, месяц и день, Вы можете увидеть всю историю нарушений технологического режима.

      Для того что бы посмотреть историю изменений только одного параметра — 2 раза кликните левой кнопкой мыши по этому параметру (двойной «клик»).

      Для печати журнала отклонений, нажмите на иконку принтера в правом нижнем углу окна программы.

       

        Работа с диспетчером Simplight

        1.1 Установить SimpLight (PRO или ENT) на нужных узлах (ПК) как сервер.

        1.2 Установить SimpLight Spacey на ПК, который будет собирать информацию со всех станций сбора данных.

        1.3 Запускаем “Конфигуратор” из элементов группы SimpSpace:

        1.4 Нажимаем пункт “добавить”:

        1.5 В Редакторе параметров узла заполняем · IP адрес станции сбора данных (нули перед цифрами не ставить: o 192.168.25.1 – ВЕРНО, o 192.168.025.001 – НЕ ВЕРНО),

        · Имя узла(любое),

        · Комментарий — если нужно

        нажимаем “Ок”:

        1.6 Справа от Списка узлов расположена область Доступных каналов.

        В Списке узлов нажимаем на созданный только что узел — справа отобразятся все существующие на нем каналы. Если Вы хотите  отображать в Диспетчере только некоторые каналы, то снимите “галки” с ненужных Вам каналов:

        1.7 Для каждой станции опроса, теги (каналы) которой Вы хотите просматривать в Диспетчере (на мнемосхемах в Мониторе или Трендами в Просмотрщике), проделайте шаги 1.4 -1.6 в  Конфигураторе.

        1.8 Запускаем модуль Монитор на всех опросных станциях.

        После этого запускаем Диспетчер(Space монитор). Отобразится окно со списком, разделенным на столько частей, сколько запущено Мониторов в сети. Работа со списком параметров такая же, что и со списком параметров модуля Монитор (на рисунке изображено 2 узла):

         

          Использование ActiveX на мнемосхеме MasterSCADA.

          1. Запускаем MasterSCADA
          2. Открываем или создаем проект, в котором будет мнемосхема, с нашем модулем.
          3. Открываем мнемосхему, на которой будет расположен наш модуль.
          4. В меню «Сервис» выбираем «Органайзер ActiveX…»

          5.  Находим наш User Control по его дружественному имени (если задан атрибут DisplaName) или по его  полному имени (namespace + имя класса)

          6.  Нажимаем на кнопку «>>>», ставим галочку «Редактируемый в схеме» и нажимаем кнопку «ОК». Данная галочка определяет: будет или нет работать наш ActiveX в режиме разработки проекта. Если модуль рассчитан для работы только в режиме исполнения, то данную галочку ставить необязательно.

           

          7. Выбираем наш модуль на палитре в разделе «Другие элементы ActiveX», и перетаскиваем его на мнемосхему

          8.  Нажимаем на кнопку и видим сообщение «Hello World!»

          Использование и динамизация свойств контрола.

          Для создания свойства контрола достаточно объявить просто свойства в классе контрола. Пример по созданию и динамизации свойств контрола можно посмотреть в проекте: «[Папка в которую установлена MasterSCADA]APIMasterSCADAExamples», класс — Examples.UserControls.PropertiesDynamization.PropertiesDynamization.

           

          Создание безоконного контрола.

          Если необходимо создать контрол с прозрачным фоном, то необходимо использовать другой базовый класс – InSAT.Library.Gui.Windowless.WindowlessControlBase. Этот класс в отличие от NetActiveXBase не унаследован от системного класса Control, поэтому для него не поддерживается дизайнер контрола (визуальное редактирования контрола в студии). WindowlessControlBase является облегченным контролом, поддерживающим только отрисовку содержимого в функции OnPaint, а также возможность реагировать на события мыши (для этого нужно переопределить функции OnMouseDown, OnMouseMove, OnMouseUp). Пример работы с таким контролом в проекте APIMasterSCADAExamplesExamples.sln.

          Контрол —  UserControlsSimpleWindowlessActiveXSimpleWindowlessActiveX.cs

           

          С точки зрения производительности такие контролы быстрее и потребляют меньше памяти, так как для них не создается окно Windows. Другим преимуществом также является то, что такие контролы имеют общий Z-порядок с большинством стандартных контролов MasterSCADA.

           

            Создание ActiveX с использованием .Net Framework.

            Создание простого .Net User Control, регистрируемого в системе как ActiveX

            1. Если у вас ещё нет проекта, в который вы хотите добавить новый User Control, то выполните пункт 1 раздела «Пример создания пустого ФБ (на языке C# в Visual Studio 2005)» из описания по созданию ФБ на C# (Создание ФБ на C#.doc).
            2. Выполните пункты 2-5 раздела «Пример создания пустого ФБ (на языке C# в Visual Studio 2005)» из описания по созданию ФБ на C#(Создание ФБ на C#.doc).
            3. Создаем новый User Control:

            4. Наследуем созданный User Control от класса InSAT.Library.Gui.NetActiveXBase

            5.  Добавляем атрибуты для регистрации ФБ как COM объекта:

            6. Значение атрибута Guid должно быть уникальным, уникальное значение можно получить при помощи VS (“Tools”->”Create GUID” в открывшемся окне выбираем GUID Format “Registry Format”, нажимаем “Copy” и “Exit”):

             

            7.  Добавляем атрибут для регистрации дружественного имени ActiveX.

            8.  Добавляем кнопку, по нажатию на которую, будет выдаваться сообщение “Hello world!”

            9. Чтобы зарегистрировать наш user control как ActiveX, необходимо просто скомпилировать наш проект.

             

             

              Создание узла АРМ в Trace Mode (часть 2)

              Создание стрелочного прибора, привязка к аргументу

              Применим для отображения параметра новый тип ГЭ – Стрелочный прибор. Для этого необходимо выполнить последовательность действий:

              выделим двойным щелчком ЛК на инструментальной панели графического редактора иконку  и выберем из появившегося меню иконку стрелочного прибора ;

              установим ГЭ , выбрав его размер таким, чтобы все элементы графики и текста на нем были разборчивы и симметричны;

              перейдем в режим редактирования и откроем окно свойств ГЭ ;

              щелчком ЛК на экранной кнопке Основная привязка откроем окно табличного редактора аргументов шаблона экрана;

              ЛК выберем уже имеющийся аргумент Параметр;

              подтвердим выбор щелчком ЛК на кнопке Готово;

              двойным щелчком ЛК откроем атрибут Заголовок и в строке Текст введем надпись Параметр;

              закроем окно свойств ГЭ .

              Для проверки правильности привязок ГЭ к аргументам экрана можно воспользоваться режимом эмуляции. Переход в режим эмуляции осуществляется с помощью иконки  на панели инструментов. По нажатию, на экран графического редактора выводится окно задания значения аргумента в соответствующем поле:

              Так, введя значение 25, наблюдаем:

              В нашем случае оба ГЭ отображают введенное значение – привязки выполнены правильно. Выход из режима эмуляции – повторное нажатие ЛК по иконке .

               

              Автопостроение канала

              Для создания канала в узле проекта по аргументу шаблона экрана воспользуемся процедурой автопостроения. Для этого:

              в слое Система выберем ЛК узел RTM_1;

              в поле компонентов узла ЛК выберем Экран#1;

              щелчком правой кнопки мыши (ПК) вызовем контекстное меню;

              в нем щелчком ЛК откроем свойства компонента Экран#1:

              выберем ЛК вкладку Аргументы;

              выделим ЛК аргумент Параметр и с помощью иконки  создадим канал класса Float типа Input с именем Параметр:

              Задание границ и уставок

              Двойным щелчком ЛК по каналу Параметр откроем бланк редактирования его атрибутов и заполним раздел Границы следующим образом:

               

              Создание генератора синуса и привязка его к каналу

              Введем в состав проекта источник сигнала – внутренний генератор синусоиды, свяжем его с созданным каналом и опробуем в работе выполненные средства отображения. Для этого проделаем следующие действия:

              откроем слой Источники/Приемники и через ПК создадим в нем группу компонентов Генераторы:

              двойным щелчком ЛК откроем группу Генераторы_1 и через ПК создадим в ней компонент Синусоида;

              захватим с помощью ЛК созданный источник и, не отпуская ЛК, перетащим курсор на узел RTM_1 в слое Система, а затем, в открывшемся окне компонентов, на канал Параметр. Отпустим ЛК.

               

                Создание узла АРМ в Trace Mode (часть 1)

                Загрузим инструментальную систему двойным щелчком левой клавиши (ЛК) мыши по иконке  рабочего стола Windows и с помощью иконки  инструментальной панели создадим новый проект. При этом в открывшемся на экране диалоге

                выберем стиль разработки Простой. После нажатия ЛК мыши на экранной кнопке Создать, в левом окне Навигатора проекта отобразится дерево проекта, содержащее слои Ресурсы, Система (с созданным узлом АРМ RTM_1), Источники/Приемники и Библиотеки_компонентов. В правом окне Навигатора проекта отобразится содержимое узла RTM_1 – пустая группа Каналы и один канал класса CALL Экран#1, вызывающий соответствующий компонент – шаблон экрана, предназначенный для отображения с помощью графических элементов (ГЭ) средств человеко-машинного интерфейса на узле RTM_1:

                 

                Создание графического экрана

                Двойным щелчком ЛК на компоненте Экран#1 откроем окно графического редактора.

                Создание статического текста

                Разместим в левом верхнем углу экрана статический текст — надпись Значение параметра.

                Для этого выполним следующие действия: на панели инструментов графического редактора ЛК мыши выделим иконку ГЭ Текст ;

                в поле графического редактора установим прямоугольник ГЭ, для чего

                зафиксируем ЛК точку привязки — левый верхний угол;

                развернем прямоугольник движением курсора до необходимого размера;

                зафиксируем ЛК выбранный ГЭ:

                Для перехода в режим редактирования атрибутов размещенного ГЭ выделим ЛК иконку  на панели инструментов;

                Для автоматического вывода окна свойств ГЭ по завершению его размещения необходимо в настройках интегрированной среды разработки в разделе РПД/Основные свойства активировать пункт Открывать свойства автоматически.

                двойным щелчком ЛК по ГЭ откроем окно его свойств;

                в правом поле строки Текст наберем Значение параметра и нажмем на клавиатуре клавишу Enter;

                закроем окно свойств щелчком ЛК по иконке , ГЭ примет следующий вид:

                Если введенный Вами текст не уместился в прямоугольнике ГЭ, выделите его и растяните до нужного размера с помощью мыши.

                Создание динамического текста, создание аргумента экрана в процессе настройки динамического текста

                Подготовим на экране вывод динамического текста для отображения численного значения какого-либо источника сигнала – внешнего или внутреннего — путем указания динамизации атрибута Текст ГЭ. Определим назначение аргумента шаблона экрана. Для этого необходимо проделать следующие действия:

                создадим и разместим новый ГЭ  справа от ГЭ c надписью Значение параметра;

                откроем свойства вновь размещенного ГЭ;

                двойным щелком ЛК на строке Текст вызовем меню Вид индикации;

                в правом поле строки щелчком ЛК вызовем список доступных типов динамизации атрибута;

                из всех предлагаемых типов выберем ЛК Значение;

                в открывшемся меню настройки параметров динамизации:

                выполним щелчок ЛК в правом поле строки Привязка;

                в открывшемся окне Свойства привязки, нажмем ЛК по иконке   на панели инструментов и тем самым создадим аргумент шаблона экрана;

                двойным щелчком ЛК выделим имя аргумента и изменим его, введя с клавиатуры Параметр (здесь и в дальнейшем ввод данных с клавиатуры будем завершать нажатием клавиши Enter);

                подтвердим связь атрибута Текст ГЭ с данным аргументом щелчком ЛК по экранной кнопке Готово;

                закроем окно свойств ГЭ.

                Графический экран будет иметь следующий вид:

                 

                  SCADA-системы на российском рынке автоматизации

                  Большинство промышленных предприятий страны нуждается в модернизации автоматизированных систем управления технологическими процессами. Действующие АСУ ТП, созданные 30 лет назад, базировались на мини-ЭВМ, которые сегодня физически и морально устарели. Впрочем, интерес к построению высокоэффективных и надежных систем диспетчерского управления и сбора данных ощутим во всем мире. К этому подталкивает, с одной стороны,  прогресс в области вычислительной техники, программного обеспечения, телекоммуникаций, а с другой, непомерно возросшая роль «человеческого фактора» в возникновении аварий и иных ЧП на транспорте, в энергетике, различных отраслях промышленности.
                  Отечественная и международная практика предлагает для построения эффективного человеко-машинного интерфейса новейшие системы диспетчерского управления и сбора данных – SCADA-системы (Supervisory Control And Data Acquisition).
                  На отечественном рынке получили признание два десятка SCADA-программ, среди них такие, как In Touch (Wonderware, США), FIX (Intellution, США), Factory Link (фирма-изготовитель United States DATA Co, США), Genesis (Iconics, США), WinCC (Siemens, Германия), RealFlex (RealFlex  Systems, США), Sitex (Jade Software, США), Trace Mode (AdAstra, Россия), Simplicity (GE Fanuc Automation, США), RSView (Rockwell Software Inc., США), Wizcon (Emation, Израиль) и другие.
                  Для их разработчиков характерно стремление создать открытые  SCADA-программы для систем управления производством, расширить сервисные возможности для тех, кто занят его комплексным обновлением.
                  Общее для SCADA-систем – автоматизированная разработка, позволяющая создать специализированное прикладное программное обеспечение (ППО) пультов операторов и диcпетчеров без реального программирования, средства регистрации сигналов об аварийных ситуациях, хранения информации  и ее постобработки, визуализации информации в виде графиков, гистограмм и т.д.
                  Для нынешнего рынка SCADA-систем показателен поворот в сторону использования  в качестве платформы операционной системы MS Windows NT.
                  Высокая степень интеграции систем автоматизации в свою очередь диктует необходимость продуманного уровня сетевого сервиса, качества технической поддержки SCADA-систем, а значит, инжиниринга и менеджмента проектов.
                  Немаловажное значение приобретает «открытость» новых систем,  возможность адаптировать пакет с минимальными затратами под конкретные нужды производства.
                  В качестве примера расскажем подробнее о двух  компаниях, предлагающих интересные решения в этой области.

                  «НАУЦИЛУС» – СИСТЕМНЫЙ ИНТЕГРАТОР
                  Научный центр информационно-логических управляющих систем («НАУЦИЛУС») ведет свой отсчет с апреля 1990 года. Он стал одной из первых фирм, рискнувших выйти в море частного бизнеса. Команду составили сотрудники одного из оборонных НИИ – разработчики высокопроизводительных, высоконадежных систем реального времени. Набиравшая темпы конверсия подтолкнула их к мысли – использовать найденные решения для промышленных систем крупных гражданских предприятий. Те остро нуждались в совершенствовании  своих АСУ ТП, базировавшихся на устаревшей вычислительной технике. На рынке к тому времени начинался бум персональных компьютеров и в офисном, и в промышленном исполнении. Этим было грех не воспользоваться.
                  Первой заявкой фирмы явилась качественно обновленная в 1993 году система управления плавильного цеха медного завода комбината «Норильский никель». Плавка меди – сложнейший процесс, где конечный результат зависит от множества факторов, управлять которыми вручную  практически невозможно. К тому же температура, загазованность, вся атмосфера в цехе была такова, что техника через полгода  выходила из строя. Система, предложенная фирмой, вобрала в себя компьютеры со специальной защитой, обеспечивающей их многолетнюю надежность, и SCADA пакет– систему обработки и управления информацией.
                  Пользователи систем контроля и управления нуждаются в мощных и в то же время недорогих решениях, отвечающих требованиям прикладных задач. Им соответствует RealFlex 4, многозадачный, многопользовательский, базирующийся на РС компьютерах пакет программного обеспечения реального времени. Он разработан фирмой RealFlex Software Inc. (RSI, США).
                  Возможности SCADA-системы во многом зависят от того, на базе какой операционной системы (ОС) они работают. В данном случае в качестве базовой ОС служит канадская QNX (QNX Software Systems Ltd.). О своем выборе специалисты не жалеют: многозадачная, многопользовательская сетевая операционная система реального времени хорошо зарекомендовала себя в работе многочисленных систем АСУ ТП, как верхнего уровня управления (АСУ ТП предприятия), так и нижнего (ОС встроенных систем и интеллектуальных контроллеров, в том числе работающих в сети АСУ ТП предприятия).
                  32-битовая операционная система обеспечивает RealFlex 4 встроенным сетевым взаимодействием «точка-точка», режимом работы с защищенной памятью и целостной файловой системой.
                  Опираясь на возможности ОС QNX, пакет RealFlex обеспечивает синхронную работу нескольких десятков рабочих мест операторов в рамках единой системы, связанных между собой по локальной сети. Система располагает всеми необходимыми средствами для построения АСУ ТП, что обеспечивает ее быструю настройку на конкретный объект пользователя, сбор и обработку данных, тревог по многотысячным точкам, поддержку работы драйверов различных устройств ввода/вывода, хранение и графическое отображение данных предыстории, вычисления в оперативном режиме и т.д. Если кабель или сетевая плата выходит из строя, то система будет автоматически перенаправлять данные через другую сеть.
                  Поскольку QNX – многозадачная система, пользователь RealFlex имеет многочисленные открытые окна, в каждом из которых одновременно выполняется самостоятельная задача и происходит обновление данных. Сканеры ввода/вывода могут запускаться постоянно в фоновом режиме без прерывания человеко-машинного интерфейса.
                  Благодаря партнерству московских специалистов и американской фирмы RSI — RealFlex Systems Inc. в странах СНГ успешно функционируют десятки систем управления производством, использующих интегрированный пакет RealFlex и операционную систему QNX.
                  Появление этого инструментального пакета означало, что теперь специалистам предприятия нет нужды самим заниматься написанием подобных программ. Несмотря на то, что SCADA-пакет – достаточно дорогой продукт, он быстро окупается. Если проводить аналогию со строительством, то появилась возможность создавать конкретные системы управления из готовых блоков. Это обусловило широкое внедрение новых инструментальных программных технологий в самых различных отраслях. Естественно, они развивались, умножали свои функции.
                  В 1995 году фирма Jade Software Ltd. (Великобритания) предложила новый универсальный интегрированный SCADA-пакет — Sitex, работающий под управлением OC QNX. Пакет Sitex рассчитан на  требовательные запросы в области систем  управления. К тому же он более доступен по цене.
                  Существующие информационные системы позволяют менеджеру, находясь в любом городе и имея доступ в Интернет, вызвать на экране «картинку» плавильного цеха Норильского горно-металлургического комбината и посмотреть, что там происходит. Удаленный мониторинг – это принципиально новый этап в развитии АСУ ТП. Такой способностью – управлять через Интернет обладает, к примеру, появившаяся в 1998 году на российском рынке система Wizcon фирмы Еmation (Израиль).
                  Назначение SСADA-пакетов – сократить сроки создания конкретных систем управления. Все они обладают, в общем-то, одинаковым набором элементов для построения подобных систем. Программистам предприятия не надо писать свою программу – есть возможность просто настроить существующую инструментальную систему под конкретные задачи. Более того, со SCADA-пакетом может работать уже не программист, а непосредственно специалист по управлению предприятия.
                  …Не так давно в фирму «НАУЦИЛУС» обратились специалисты ТЭЦ-25 Мосэнерго с просьбой помочь автоматизировать котлотурбины трех блоков, системы химводоочистки и экологического контроля.            Сложность технологических процессов такова, что без средств автоматизации их уже невозможно реализовать. Внимательно изучив «фронт» будущих работ, проведя системный анализ, представители фирмы занялись подбором необходимых компьютеров, контроллеров и иной техники как российской, так и западной. Возможности, заложенные в SCADA-пакете RealFleх, позволили  в короткие сроки качественно обновить АСУ ТП энергопредприятия, обеспечив, что немаловажно, взаимодействие новых решений с ранее введенными компонентами автоматизации. Сдав систему, «НАУЦИЛУС» продолжает опекать свое детище, помогая  поэтапно наращивать, развивать ее. Открытость систем, возможность модернизации – существенное их достоинство.
                  В активе фирмы, помимо автоматизации системы управления на «Норильском никеле», внедрение АСУ ТП в АО «Северные магистральные нефтепроводы» (гор. Ухта), на Оренбургском газоперерабатывающем заводе, «Салаватнефтеоргсинтезе», водоканале гор. Миасс, Череповецком городском узле электросвязи, на важных народнохозяйствен-ных  объектах гор. Северска, Ангарска, Братска, Альметьевска, Набережных Челнов и других. Заказчиками  выступают главным образом предприятия, представляющие естественные монополии – энергетику, нефте- и газодобычу, металлургию. «К сожалению, машиностроители, легкая промышленность пока в тени. Все ссылаются на нехватку средств», – как отметил директор «НАУЦИЛУСА», к.т.н. А.Н. Иванов.
                  «НАУЦИЛУС» приступает к комплексной автоматизации зданий, используя SCADA-системы. Закладывая их в проект при строительстве, фирма многократно снижает общие расходы, по сравнению с  созданием пожарной сигнализации, охранной системы, домофонной связи и т.д. по отдельности. То есть речь идет о создании единой структурированной информационной сети. Используя кабельную систему, которая не намного сложнее, чем обычная телефонная разводка, разработчики обеспечивают проводку через нее всевозможных сигналов тревоги, управления и информации. Это дает возможность дистанционно регулировать вентиляцию, температуру, освещение, кондиционирование воздуха в помещениях.

                  РОССИЙСКАЯ МАРКА AdAstra
                  Российская фирма AdAstra Research Group, Ltd образована в 1992 году. Начав с нуля, она постепенно превратилась в крупнейшего отечественного производителя программного обеспечения для промышленной автоматизации. По данным за 1999 год SCADA-система этой компании TRACE MODE занимала примерно 48 процентов российского рынка, став ведущей системой программного обеспечения в стране.
                  За минувшее десятилетие AdAstra, подчеркивает президент Л.В.Анзимиров, не только сохранила потенциал разработчиков, но и вывела свою продукцию на международный уровень, став конкурентом ведущих зарубежных систем по качеству и объему функций, по экономическим показателям.
                  Привлекательность TRACE  MODE в самой фирме объясняют несколькими основными факторами. Прежде всего, это высокая функциональная насыщенность SCADA-системы, постоянное ее совершенствование, ориентация на новые технологии. Свои результаты дает политика бесплатного написания и предоставления пользователям драйверов УСО, качественная техническая поддержка разработчиков АСУ на местах. Естественно, сказывается разумная ценовая политика фирмы: TRACE MODE примерно вдвое дешевле зарубежных аналогов, не уступая им по качеству.
                  Предложенная московскими специалистами система предназначена для сбора, обработки, графического показа и управления технологическими процессами в реальном времени. На ее основе можно создавать автоматизированные рабочие места операторов-технологов, диспетчеров, сменных инженеров и т.д., а также вести разработки полнофункциональных распределенных АСУ ТП масштаба предприятия. Практика многократно подтвердила все эти возможности.
                  SCADA-система TRACE  MODE в настоящее время имеет свыше 4000 инсталляций — работает в энергетике, металлургии, нефтяной, газовой, химической и других отраслях промышленности, в коммунальном хозяйстве, по числу внедрений в России значительно опережая зарубежные пакеты подобного класса.
                  Она несет, в частности, службу на центральном пульте диспетчерского управления Красноярской ГЭС, на Харанорской и Гусино-озерской ГРЭС, в региональной системе управления энергопотоками Татарстана. Недавно запущена на первых двух энергоблоках по 210 Мвт ГРЭС «Нассирия» (Ирак). Широко используется в атомной промышленности (НПО «Маяк», ПО «Радон»). Систему оценили на Старо-Оскольском электрометаллургическом комбинате, где  автоматизировали линию непрерывной разливки стали, а затем, печь металлизации, используя последнюю модификацию пакета, и на Братском алюминиевом заводе. Еще в середине 90-х годов TRACE  MODE «прописалась» на АвтоВАЗе, в Центральном банке РФ, Центре подготовки космонавтов.
                  Фирма все активнее выходит на международный рынок, участвуя в крупнейших зарубежных выставках Европы и Азии. Год назад были осуществлены первые продажи за рубеж. Российская система вызвала большой интерес специалистов на крупнейшей в Европе выставке по промышленной автоматике –  BIAS-1998 (Милан, Италия). AdAstra имеет дистрибьюторское соглашение с итальянской компанией Applidea Srl. Аналогичные договоренности о распространении TRACE MODE заключены с компаниями Японии, Малайзии, Таиланда и Южной Кореи.
                  В эти дни реализуется проект по созданию АСУ на крупнейшем нефтеперерабатывающем предприятии Европы «Сарос» (Италия) с применением TRACE MODE.
                  Детище российской школы разработки, эта SCADA-система служит наглядным примером того, как надо отлаживать технологию производства коммерческих продуктов.
                  Жесткая конкуренция способствовала тому, что TRACE MODE оптимально адаптирована к современным российским условиям. Она, к примеру, обеспечивает поэтапное обновление аппаратных средств АСУ ТП предприятия. Вместо того чтобы выбрасывать жизнеспособное, но дряхлеющее оборудование, здесь могут с ее помощью заменять лишь вышедшие из строя устройства. TRACE MODE ориентирована на стандартные и легкодоступные, а потому и недорогие программные средства.
                  В 1988 году фирма перешла на пятую версию TRACE MODE. Она основана на DCOM – базовой 32-разрядной технологии корпорации Microsoft. Благодаря современной архитектуре система реального времени обладает очень высокой производительностью, содержит ряд новых технологий проектирования. Среди них разработка распределенной АСУ ТП как единого проекта, автопостроение, оригинальные алгоритмы обработки сигналов и управления, объемная векторная графика мнемосхем, единое сетевое время, уникальная технология графического просмотра архивов на рабочих местах руководителей.
                  Отдельные модули системы теперь легче сопрягаются между собой, а это означает, что АСУ ТП на базе TRACE MODE нетрудно поддерживать, развивать и интегрировать в корпоративные информационные системы.
                  Новое поколение средств проектирования TRACE MODE 5 ориентировано на создание распределенных АСУ единым проектом – от контроллеров до операторских станций, серверов архива и рабочих мест руководителей. Это позволяет в 1,5-2 раза сократить количество разработчиков, занятых в проекте. При разработке распределенной АСУ объемом в 1000 I/O выигрыш может достигать $5000 на проект (в России) и $50.000 на Западе, для АСУ в 10.000 I/O — соответственно $12.500 и $125.000.
                  Единый проект дает возможность формировать распределенную базу каналов, лучше проектировать информационные структуры, а также использовать технологии автоматического построения и поддержания проекта. Он позволяет инженеру службы эксплуатации быстро проследить информационные связи в рабочей среде. В итоге систему удается обслуживать меньшими силами.
                  Технология автопостроения означает автоматическое генерирование, поддержание и обновление информационных структур проекта АСУ ТП по основным данным.
                  Использованное в системе автопостроение освобождает разработчика от рутинных операций по «набивке« баз каналов. Он может уделить главное внимание решению важнейших проблем разработки. Наряду со значительным выигрышем в производительности труда удается сэкономить 7-10% от общей стоимости проекта АСУ ТП. Процедура авто-построения открывает дорогу для автоматического обновления  информационных связей на всех узлах системы, оптимизации  структуры проекта в ходе его реализации и эксплуатации.
                  TRACE MODE пятой версии – это новая степень свободы. Разработчики АСУ ТП могут  свободно конфигурировать задачи математической обработки, создавать собственные формы графического отображения информации. И, конечно, очень важно, что система ориентирована на работу в Интернете.
                  В TRACE MODE 5 входят около 50 различных модулей, различающихся набором функций или мощностью. Иными словами, пользователь имеет большой выбор. К тому же AdAstra предоставляет бесплатно диск с инструментальной системой на час работы: заказчик, таким образом, заблаговременно может протестировать предлагаемую ему систему, проверить правильность своего выбора.
                  Глобальное информационное хранилище обеспечивает надежное сохранение истории технологического процесса на удаленных дублированных серверах: запись 64000 параметров с дискретностью до 0.001 с. Информацию о ходе технологического процесса можно просматривать из любой точки планеты при помощи сети Интернет. Горячее резервирование и восстановление после сбоя является встроенной функцией системы. Причем работа резервированных систем полностью автоматизирована.
                  Помимо разработки программного обеспечения, специалисты AdAstra предлагают комплекс услуг, связанных с сопровождением проектов. Внимательно отслеживая их судьбу, профессионалы оказывают техническую поддержку (бесплатную – в течение года). Пользователь имеет доступ ко всем данным проекта с любого компьютера.

                   

                  P.S. Деньги быстрее, чем за час! Срочная потребность в денежных средствах – частая ситуация в современных условиях как для бизнеса так и для личных нужд. Автоломбард Москва — быстрое и оперативное решение подобных вопросов.